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Welcome to OmniGraffle 

HELLO

Welcome to This Manual 

Everyone needs to communicate visually, because everyone 
has ideas that can’t be expressed by words alone. 
OmniGraffle exists to help you convey your ideas visually, 
make sense of them, and present them to others as clearly 
as possible.

Any graphics program can make a beautiful picture to 
express glory or Weltschmerz, but OmniGraffle can make 
a beautiful picture to express this database contains forty-
seven tables or let’s put the cactus over there in the corner. 
The next time you have a complicated concept you need to 
sort out, or someone wants you to “show me don’t tell me”, 
you’ll be able to whip up an organized, attractive diagram 
in no time.

Of course, you can also use OmniGraffle to create everyday 
documents like photo albums, yard sale flyers, CD covers, 
garden layouts, newsletters, and almost anything else you 
can think of. Draw pretty pictures, lay out text, connect shapes 
together, turn outlines into graphics, drag in images... the 
list goes on and on.

OmniGraffle can handle a huge set of different tasks, and 
we are constantly surprised by the new uses people find for it. 
This manual is here to get you acquainted with the software 
so that you can discover how you would like to use it.

You can refer back to this manual for general guidance 
and ideas. If you have a question about a specific detail, try 
the searchable onscreen help files in OmniGraffle’s Help 
menu.
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Diagram styles define the appearance of a diagram: use them to style 
a diagram as you enter it in the outline view, or apply one to an existing 
diagram or OmniOutliner file for instant beauty.

New keyboard and mouse shortcuts (like selecting a shape and then 
Command-clicking the canvas) ease the creation of epic quantities of 
data.

In OmniGraffle Pro, use notes to attach extra information to objects and 
maintain consistency with OmniOutliner documents.

Drawing and Drafting Improvements
In OmniGraffle Pro you can quickly create tables and 
easily populate them with data.

The new pen tool replaces the polygon tool; it 
supports Bezier curves, which we’re pretty sure is 
French for “bendy lines”.

The Edit menu of OmniGraffle Pro now contains commands for 
mathematically combining multiple shapes into one object.

When you’re drawing something to scale, OmniGraffle Pro’s new ruler 
really comes in handy. Set up a ruler scale such as “1 in = 2 ft” or “100 
px = 1 km” and OmniGraffle takes care of the rest.

The style brush can now pick up specific style attributes.

The new magnet tool can edit an object’s magnets right on the canvas.

Import & Export Improvements
OmniGraffle now supports LinkBack, a lovely way to embed data from 
one application in a document of a different application.

Two new export formats are 
available: SVG (for OmniGraffle 
Pro) and vector PICT.

Nearly all existing import and 
export options have been greatly 
refined and improved.

This is the fourth major release of OmniGraffle, and 
we’d like to take a few moments to tell our upgrading 
customers what is new since version 3. If you’ve never used 
OmniGraffle, congratulations — everything is new!

We will cover each of these features in more depth in later 
chapters, so whether you’re a new user or not, you’re 
welcome to skip along to the next chapter (on page 4).

WHAT’S NEW IN OMNIGRAFFLE 4

Interface Improvements 
The utility drawer makes a stronger 
connection between canvases, layers, 
and the documents they belong to. It 
also facilitates drag-and-drop actions 
between documents.

OmniGraffle Pro can base multiple 
canvases on a master canvas, giving 
them a common foundation.

Eighteen inspectors have been 
consolidated into three inspector 
windows, with even more functionality. 
Each inspector window has tab-
like buttons for switching between 
inspectors.

Brainstorming
Use the startlingly useful outline view, in the utility drawer, to rapidly 
enter data from the keyboard; watch as your outline is transformed into 
a diagram.
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 Mount the Disk 
If you have a physical OmniGraffle disk that came in a box, put the disk in 
your Mac’s CD or DVD drive. If you have downloaded an OmniGraffle disk 
image, double-click it (the .dmg file) to mount it.

INSTALLATION

Choose from the three different types of licenses:
A Computer license can be used by any user on that one computer. This is 
the most basic type of license.

A Personal license can only be used when you are logged in as the user 
who installed it. You can, however, install and use it on any number of 
different computers as long as only one copy of the application is running 
at one time.

A Network license is for environments with many users (such as companies 
and schools) to allow a certain number of users on the network to use the 
software at once.

Once your license key is accepted, click the Save button and you’re set!

 Run OmniGraffle
Double-click OmniGraffle’s icon to run it; if this is 
the first time you’ve used it, and you don’t have any 
licenses installed yet, you’ll see the Licenses dialog. If 
you don’t see it, and you want to install a license, select 
Licenses... from the OmniGraffle menu.

 Copy the Application 
Drag the OmniGraffle application icon from the disk into 
your Applications folder. This can be the Applications 
folder in the root level of your hard drive (so that all users 
on your Mac can access it) or the one in your home folder 
(so that only you can access it).

If you already have a copy of OmniGraffle installed, you’re asked whether 
you want to replace it. If you don’t mind losing your old copy, go ahead and 
replace it; otherwise try moving the old copy somewhere else or renaming it.
When the copy is done, you don’t need the disk anymore; eject the CD or eject 
and delete the disk image.

 Add a License 
Click the Add License... button. In the dialog that appears, type your name 
into the Owner field; if you bought a license online, the owner name must 
be exactly the same as the owner name in your e-mail receipt; even the 
capitalization must be the same.

Type your license key into the License Key field. If you bought OmniGraffle 
in a physical box, your license key should be printed on a sticker attached to 
the CD sleeve. If you bought OmniGraffle online, you can copy and paste the 
license key from the e-mail receipt.

Registering OmniGraffle
If you bought OmniGraffle in a physical box, it helps to register 
your new license at our web site. This lets us connect your 
license key and your name so that we can support you better: 
you can upgrade to new versions of the software at discounted 
prices, and we can retrieve your license key for you later if you 
lose it. We’ll never, ever, ever give your personal information to 
anyone else, or do anything inappropriate with it (ever).
http://www.omnigroup.com/applications/registration/
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LET’S TRY IT
Meet the Canvas

The utility drawer contains the handy new 
outline view. It also has a list of layers on 
the canvas, and in OmniGraffle Pro, a list of 
canvases in the document.

These crafty stencils provide quick access 
to objects you use frequently. You can even 
make your own and share them with other 
creative geniuses.

Fifteen delectable inspectors give you complete 
control over the current selection, from text, 
to objects, to a whole canvas. Summon and 
dismiss each one as you see fit.

The innocuous ruler is actually a powerful 
alignment, spacing, and scaling tool. 
Work with the units that make the most 
sense, from pixels to miles.

The indispensable tool palette can live in the toolbar, 
or it can float in a separate window of its own.

The customizable toolbar is a standard element of 
many Mac OS X applications. Fill it with your favorite 
controls to work more quickly.

The canvas is your tabula rasa, where your creation takes form. Create 
objects, connect them with lines, and move them around as you see fit.
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With the Shape tool selected, click and drag across the canvas to create a 
reasonably-sized shape object.

That was fun. Let’s create another shape in a different way: from the Stencils 
menu, choose Basic. This summons the basic stencil, which contains a 
whole lot of commonly-used objects. From the stencil, drag a shape that 
appeals to you and drop it on the canvas near your first shape.

 Text
Objects have a lot more meaning when they’re labeled. Click the Text tool 
once; it looks like a letter ‘A’.

 Your Quest
OmniGraffle starts you out with a blank canvas. Your quest is to put objects 
on that canvas and connect them together.

 Shapes
If you don’t have a blank document open yet, select New from OmniGraffle’s 
File menu.

Let’s start simply, by creating a single shape. Click the Shape tool once; it’s 
the second button in your tool palette, and probably has a white square on 
it (unless somebody changed it on you).

MINI-TUTORIAL: ESSENTIAL TOOLS
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With the Line tool selected, maneuver the crosshair onto your first shape, 
see the shape pulsate to let you know you’re about to connect to it, and 
click. Then put the crosshair on your second shape, see it also make with 
the pulsation, and click again.
 

Now you have two shapes connected by a line. This is the soul of OmniGraffle: 
connected objects stay connected. The line stretches and moves to keep the 
shapes connected no matter how they are restyled or moved around.
 

You can use lines to represent any kind of relationship between objects: 
related ideas in a brainstorm, ancestry in a family tree, or order in a 
sequence, just to name a few. Remember that, when creating lines, the 
order in which you click objects matters; the first object you click is the 
“source” of the line, and the second object you click is the “destination”. 
This determines at which end of the line the arrowheads appear and affects 
objects’ hierarchy when you use the automatic layout or the outline view.

 You’ve got it
Every object in OmniGraffle is a shape or a line; any object (even a line) can 
be connected to any other object by a line.

With this knowledge, you can diagram almost anything. The rest is just 
details.

With the Text tool, click your first shape object. You get an insertion 
point for entering text. Type something to identify the object, like “1” or 
“rectangle” or “asdf”.

Click the Text tool once more, then click the other object. Name it something 
else, like “2” or “not rectangle” or “Douglas”.

 Lines
Things are about to get interesting. Click the Line tool once; it should be 
the fourth tool in your palette, and it looks like... a line.
 

MINI-TUTORIAL: ESSENTIAL TOOLS
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 Welcome
OmniGraffle excels at clarifying complex relationships, and nothing says 
“complex relationships” like a Shakespeare romantic comedy. Let’s try 
to make some sense of Much Ado About Nothing, and learn a bit about 
OmniGraffle in the process. Of course, this play is just a handy example; 
if there’s another story you’re more familiar with, you can go ahead and 
use it instead. The Tale of Genji, Steppenwolf, The Fifth Element... Whatever 
works best for you.

When you’re finished, you’ll have a diagram that looks something like this 
one. Yes, it’s very nice, thank you. You can make one too; it’s easy.

 
Create a fresh document by selecting New from the File menu and we’ll 
get started.

 Creating objects with the outline view
You’ve already learned in the mini-tutorial how to create shapes and 
connect them. But there’s another clever way to enter data: the outline view. 
If you’ve ever used an outliner (say, OmniOutliner, a fine product indeed), 
this should come naturally to you. If not, you’ll probably pick it up easily 
anyway.

First, if the utility drawer isn’t open, select Show Utility Drawer from the 
View menu (or click the Utilities icon in the toolbar). The Outline tab at the 
top of the drawer is selected by default.
 

The big blank area in the drawer is your outline, which, just like the canvas, 
starts out empty. Don’t worry about the controls at the bottom of the drawer 
just yet. Double-click the outline area to create your first item. An item called 
“Topic” appears in the outline, and simultaneously a shape labeled “Topic” 
appears on the canvas.

The item’s text is already highlighted, so you can just start typing to rename 
it. This item represents our first character, so type “Don John”.
 

 
 
 
 
 
 
 
 

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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Now press the Tab key; Benedick in the outline becomes indented, and 
the corresponding shape on the canvas gets a connection line from Don 
Pedro. With Benedick still selected, press Return to create another item at 
the same level and name it “Claudio”. Now you have two characters that 
“belong” to Don Pedro.

 
Now use the same technique to add Beatrice and Hero underneath 
Leonato; they’re his niece and his daughter. In the diagram, you’ll see that 
they exist on the same level as Benedick and Claudio, but are connected to 
Leonato instead of Don Pedro.

 Line labels
To clarify the relationships we have so far, let’s use the Text tool add labels 
to the connection lines.
 
Click the Text tool twice; it’s the one with a letter ‘A’ on it. If you click a tool 
twice, you can use it several times in a row. If you only click once, it reverts 
to the Selection tool after one use.

Press Return to finish with this item and move on to the next one. A new 
item appears below the first one in the outline, and a new shape appears 
on the canvas. Name this one “Don Pedro”.

 
Press Return once more to create a third item, and name it “Leonato”. Now 
you have three items in your outline and three shapes on your canvas.

 Outline hierarchy
It’s nice that you can create shapes quickly from the keyboard like this, 
but the real magic is in adding depth to the outline. All of the characters 
you’ve created so far exist on the same level, but now let’s add some more 
characters one level below them.

The next two characters are soldiers who fought under Don Pedro’s 
command, so we’ll add them below him in the diagram. Click the Don 
Pedro item in the outline to select it, then press Return to create a new item 
below it. Name the new item “Benedick”.
 

Continued on next page

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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Position the pointer over the line between Don Pedro and Claudio. The line 
becomes highlighted; click it. Type “boss” into the label’s text to show that 
Claudio works for Don Pedro.
 

Add labels to the three remaining lines in the same way, indicating that 
Don Pedro is also Benedick’s “boss”, and that Leonato is Hero’s “father” 
and Beatrice’s “uncle”. 

 Making more connections
You’ve already got a fine diagram, but sometimes you want to diagram 
relationships that are not strictly tree-like. Let’s manually add some more 
connections. If, while you do this, any connection lines look awkward, 
feel free to use the Selection tool to drag shapes into more comfortable 
locations. You can’t ruin anything by just moving shapes around.

Let’s make the Line tool match the lines already on the canvas. Click and 
hold on the Line tool button in the tool palette, and a menu appears. Under 
Canvas Styles, select the Straight, Stroke: Black entry. Now the lines you 
make with the Line tool will look the same as the lines that were created 
automatically by the outline view.

Add the connection lines just like you did in the first tutorial: with the Line tool 
selected, click one shape then the other. Make connections and label them 
to signify the following relationships: Don John and Don Pedro are half-
brothers; Don Pedro and Leonato are friends; Hero and Claudio are in love; 
Benedick and Beatrice are (eventually) in love.
 

Now that the diagram is more complicated than a simple outline, you won’t 
be needing the outline view any more. Choose Hide Utility Drawer from 
the View menu or click its icon in the toolbar. 

 Styling objects
Look at your work so far—no literary minutia can escape your 
organizational prowess! Okay, so, the diagram makes sense, but it’s 
not particularly attractive. Let’s pretty up those objects with some style 
attributes. Start by selecting Don John.

We’re going to meet the inspectors: convenient little windows full of 
controls that you can use to modify any object on the canvas, or the 
canvas itself. There are six Style inspectors, each 
one of which controls a certain element of the 
selected objects’ appearance. The first inspector 
we’ll use is the Fill inspector; if you don’t see it on 
your screen, select Fill from the Style section of 
the Inspectors menu.

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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Right now the selected object has a plain white fill color. Click the color well 
in the inspector’s upper-right corner and then use the Colors panel that 
appears to choose a new fill color. If you like, you can even choose a blend 
style from the menu at the left of the inspector, then choose a different 
color for each well that appears.

 

Next let’s use the Lines and Shapes inspector to change the line drawn 
around the outside of the shape. There are six icons across the top of the 
Style inspectors window; click the second one to switch to the Lines and 
Shapes inspector. From there, try setting the stroke thickness to 2pt, and 
the corner radius to 5pt. This makes for a nice, heavy, rounded stroke 
around the shape. Choose a nice stroke color just like you did for the fill 
color.
 

Switch to the Text inspector and click the Font button (the one with a big 
letter ‘A’); this summons the standard Mac OS X font panel. Choose a nice 
font, then click the color well next to the Font button and choose a nice 
color. Now you should have one quite charming shape object.

 Proliferating styles
The next step is to apply the same styles to your other shapes without 
repeating every step for each one.

Switch to the Summary inspector; it contains a list of all style attributes for 
the currently selected object. Each style attribute is represented by a tiny 
square “style chit” and a text description. With the Don John shape still 
selected, drag its “All Styles” chit from the Summary inspector and drop it 
onto the Don Pedro shape in the diagram.

 

Continued on next page

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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Whoa! That’s pretty easy. Do the same thing to Leonato so that all of the 
elder generation characters have a consistent appearance.

 More selecting and styling
Let’s style the remaining objects. A quick way to select lots of shapes at 
once is with the Selection inspector, which is part of the Canvas inspectors 
window. If you don’t see it on your screen, select it from the Inspectors 
menu.
 
The Selection inspector lists all of the different kinds of objects on the canvas, 
based on their styles. The Selection inspector shows that you have one out 
of three colored rectangles selected. There should be an item representing 
the four plain white rectangles with black strokes; click it to select all such 
objects at once, and it changes to show that you have selected four of four 
such objects.

You can use the Properties inspectors to change aspects of an object that 
are not strictly related to its visual style. We’ll use the Geometry inspector 
to change the size of the four selected objects. If the Geometry inspector 
is not on your screen, select it from the Inspectors menu. In the width 
and height fields, enter some new values to make these shapes somewhat 
larger than the others.

 
Use the Style inspectors to simultaneously style all four shapes in in a way 
that differentiates them from the others. Here we’ve chosen a different 
color, a slightly thicker stroke, and a larger font.

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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 Layers
Layers contain separate sets of objects on one canvas; the layers of a 
canvas appear one on top of another according to their order. We’ll 
put our background image on a new layer to keep it separate from the 
character diagram.

Show the utility drawer again, and this time click the tab labeled Canvases 
(if you’re using OmniGraffle Pro) or Layers (if you’re using OmniGraffle 
Standard). In OmniGraffle Pro, click the disclosure triangle to the left of 
“Canvas 1” to see the layers. In OmniGraffle Standard, the layers are 
already visible.
 

You only have one layer right now, so let’s add another one. Click 
“Layer 1” to select it, then click the plus button at the bottom of the 
drawer. A new layer is born. You can name it if you like; something like 
“Background” should suffice.
 

The order of layers is important; stuff on top layers appears in front of 
stuff on bottom layers. We want the background to appear behind our 
relationships diagram, so drag the new layer and drop it below the other 
one in the list.

 

Let’s concentrate on the background layer. The layer you’re working with 
right now has a pencil icon to the left of its preview in the drawer. If the 
background layer doesn’t have the pencil icon, click just to the left of the 
layer preview to put it there.

Find a nice background image on one of your disks. Drag the image 
file from the Finder and drop it on the canvas area. A new shape object 
containing the image is created on the background layer.
 

Continued on next page

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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 Overachievers’ Corner
If you’re ambitious, try getting your diagram to look like this.

 
It might be helpful to lock the background layer by clicking its little padlock 
icon in the utility drawer; this prevents you from accidentally selecting or 
changing the background image.
 
The title can be created with the Text tool, the style of the connection lines 
can be changed from the Lines and Shapes inspector, and the positioning 
of the line labels can be changed with the Geometry inspector.

Drag the selection handles on the corners of the shape to stretch it to a nice 
big size; hold Shift as you drag to keep the image from getting distorted. 
Then use the Image inspector to set the image’s opacity to about 10%.

 Completion

Now you have an attractive, informative diagram. You know how to use 
the outline view to create objects, how to label and connect them, and how 
to add styles. You know how to propagate styles around to many objects. 
You know how to use multiple layers. At this point, you’re pretty much 
unstoppable!

Presentation mode
When you’re ready to show your document to a room full of 
people, use OmniGraffle Pro’s presentation mode. Just select 
Presentation from the View menu, and your diagram grows to fill 
the entire screen. Click or use the arrow keys to move between 
canvases, point at an object to highlight it, and click an object 
to perform its assigned action. If you have two displays, you 
can even show the presentation on one while editing the canvas 
normally on the other. Classy, yes?

TUTORIAL: MUCH ADO ABOUT GRAFFLING
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INSPECTORS
The inspectors are little windows you use to edit the objects 
and canvases in your diagrams. You can drag them around 
by their title bars like any other window, or open and hide 
the different panes in each inspector window by clicking the 
icons across the top of each one.

If you need a hint about the purpose of a particular control 
on an inspector, just put the pointer over it for a moment. 
Most controls show a help tag with a brief description of 
their purpose.

AN IN-DEPTH LOOK

Style: Fill inspector
This fills the selected shape with a color, a gradient, 
or nothing at all. If you choose a gradient, you’ll 
see more color wells and controls for setting the 
gradient’s direction and position.

Style: Lines and Shapes inspector
Use the top half of the inspector to determine the 
style of a shape’s outline or of a connection line.

If you have a shape selected, the bottom half of 
the inspector can be used to change that most 
important aspect of a shape object: its shape.

If you have a connection line selected, the bottom 
half of the inspector can be used to change the 
line endings, what kind of path the line follows, 
and how it behaves when crossing other lines.

Style: Shadow inspector
Here you can choose whether the selected object 
should have a shadow, and whether the shadow 
should appear above or below overlapping 
objects on the same layer.

If you choose to give the selected object a shadow, 
you can set its color, position, and blurriness 
here.

Style: Image inspector
You can place an image inside a shape. Select 
the Image checkbox to choose an image file, or 
just drag an image file into the well or onto the 
shape itself.

Once you have selected an image, you can use 
the other controls on the inspector to position and 
size it within the shape.

Style: Text inspector
Here are the controls for what an object’s text 
looks like and where it is positioned relative to 
the object itself. You can set the text’s horizontal 
and vertical alignment, how to handle overflowing 
text, and of course the font and color.

Style: Summary inspector
This is a list of all style attributes for the selected 
object. You can drag any or all of these styles onto 
an object on the canvas, or onto a class of objects 
in the Selection inspector, to apply them to that 
object.

STYLE INSPECTORS
These inspectors control everything about the appearance 
of the objects that are currently selected on the canvas. 
Most changes you can make to an object’s appearance are 
immediately visible, so if you’re not sure how something 
works, just play with it a bit and watch how the selected 
object changes.

Continued on next page
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PROPERTIES INSPECTORS
These inspectors are concerned with everything about 
the currently selected objects apart from their visual style. 
Object positioning, size, and special behaviors are the kind 
of things you can control here.

Properties: Geometry inspector
Use this inspector’s  text fields to exert precise 
control over the position and size of the selected 
object. You can also change the orientation of an 
object with the rotation angle controls and flip 
buttons.

If the selected object is a line label, you can control 
the label’s position and orientation in relation to 
its line.

By the Way...
Inspectors are pretty smart. Try clicking in a number input field, 
then pressing the up or down arrow keys; the number increases 
or decreases step by step. You can enter simple arithmetic in 
these fields, like “2 * 3 inches”. Also, you can even enter values 
in whatever units you like. If OmniGraffle supports those units, 
they’ll be automatically converted to the units set up in the ruler. 
(Sorry, no furlongs.)

Properties: Connections inspector
One of the most important things OmniGraffle 
can do is use connection lines to logically 
associate objects. This inspector has controls for 
determining how the selected object connects to 
other objects.

There are a number of magnet presets to indicate 
where connection lines should connect to a shape. 
Different types of objects also have special controls 
here for determining how they connect to other 
types of objects, if at all.

Properties: Action inspector
You can set up an action to be taken when the 
selected object is clicked with the Browse tool. This 
is nice for creating interactive documents that make 
it easy for a user to navigate between canvases, 
open another file, or execute AppleScripts.

Properties: Note inspector
Notes are a handy way to store arbitrary 
information about objects in a diagram. An object 
with a note displays the note in a tag when you 
rest the pointer over it for a moment.

CANVAS INSPECTORS
While the other inspectors control attributes of individual 
objects on a canvas, these ones control attributes of the 
canvas itself.

Canvas: Size inspector
This inspector deals with the size, scale, and 
orientation of the current canvas, especially in 
relation to the printed page. You can select a 
canvas size based on how the canvas fits printed 
pages, or you can enter any arbitrary size. 
Likewise, you can scale the canvas to best fit the 
objects on it. You can also set up the orientation 
of pages (portrait or landscape), the zero-point of 
the rulers, and the page margins.

Canvas: Grid inspector
A grid can be helpful in getting objects laid out in 
just the right places. Use this inspector to control 
the grid’s size and visibility, and to make objects 
snap into place on the grid as you move them.

INSPECTORS
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TOOLBAR

Just like in other Mac OS X applications, you can customize 
the toolbar to contain whichever controls you like, or hide 
it completely. Use the View ‣ Customize Toolbar... 
command to set up the toolbar however you like it, and use 
the white button on the right side of the title bar to show or 
hide the toolbar.

Most toolbar items just replicate menu items in a more 
convenient location. The notable exception is the tool 
palette, which is essential for creating diagrams. See the 
next section for more information about the tool palette.

Canvas: Selection inspector
The Selection inspector is a handy little list of all 
the different types of objects on the canvas. Click 
an entry to select all objects that match it, instead 
of selecting the objects yourself one by one. Then 
you can change all of your purple ovals to key-lime 
octagons,  or resize them all with the Geometry 
inspector, or give them all a shadow, or just delete 
them all, or whatever you need to do.

Canvas: Alignment inspector
Use this section to align objects in relation to 
each other or to the canvas. Click the vertical 
or horizontal align buttons to line up the objects 
just right. There are also buttons for distributing 
objects evenly along the vertical or horizontal axis, 
and for putting a certain distance between objects. 
The Align to Canvas checkbox allows for lining 
objects up according to the canvas edges.

Canvas: Diagram Layout inspector
OmniGraffle can move objects around the canvas 
logically, based on their connection lines to other 
objects. Use this inspector to set when objects 
should be rearranged, or to do so on demand. 
You can also set the direction of the hierarchy, 
choose how child objects should be ordered, 
and force selected objects into certain hierarchy 
levels. 
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Selection
The Selection tool is the most basic tool; 
click an object to select it, or drag an 
object to move it. Drag a line’s points to 
reposition the line.
Drag a box around several objects to 
select them all at once, or hold Command 
as you click to add more objects to the 
current selection.

TOOL PALETTE

These are the tools you use to interact with the canvas. Each 
tool has a unique purpose, from creating new shapes to 
moving your view around. Click a tool once to activate it for 
one use; the number 1 appears on the tool to remind you 
of this. Click a tool twice to keep it activated until you click 
a different tool.

The Shape, Pen, Line, and Text tools have style menus that 
you can use to change the style of the objects that the tool 
creates. Click the tiny downward triangle on the tool, then 
select a style from the list. You can also choose Inspect Style 
and then use the Style inspectors to edit the tool as if it were 
an object on the canvas.

Text
You can use the Text tool to create text 
objects, or to edit the text of existing 
objects. Click an empty spot on the canvas 
to create a text object that resizes to fit the 
text inside it. Click any object already on 
the canvas to edit its text.

Line
The Line tool establishes connections 
between objects. Click the object you wish 
to connect from, then the object you wish 
to connect to. You can also create lines 
that are not connected to anything in 
particular: double-click an empty spot on 
the canvas to end the line there.

Pen
Use the Pen tool to create shapes to 
your own liking. Click somewhere on the 
canvas to start drawing a shape, then 
keep clicking wherever you like to add 
more points. Click and drag to create 
points with curve handles. Double-click or 
press Return to create the final point.

Shape
Click and drag somewhere on the canvas 
to create a shape.
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Hand
The Hand tool is a hand that you can use to 
drag the canvas around and reveal areas of 
it that are hidden offscreen.

Don’t try dragging the canvas around with 
your actual hand. It doesn’t work. (Trust 
us.)

Browse
The Browse tool is for using interactive 
OmniGraffle documents. If you click an 
object that has an action (set with the Action 
inspector), its action is performed. This can 
move to another part of the document, open 
a file, visit a URL, or run an AppleScript.

Zoom
Click somewhere with the Zoom tool to get 
a closer view of that area of the canvas, or 
Option-click to zoom out. You can also click 
and drag to indicate the exact rectangle 
you’d like to zoom in on.

Magnet
Click an object to stick a new magnet on 
there, or drag existing magnets around to 
rearrange them. Option-click magnets to 
get rid of them.

Style Brush
The Style Brush works a lot like the rubber 
stamp, but with styles instead of whole 
objects. Click an object to suck up its styles 
(stroke, fill, font, and such) into the brush, 
then click another object to apply those 
styles to it. You can use the tool’s pop-
up menu to choose exactly what kinds of 
styles to absorb, or to clear the contents of 
the Style Brush.

Rubber Stamp
The Rubber Stamp tool is handy for 
creating multiple copies of an object. 
Click an object to “pick it up”, then click 
anywhere on the canvas to put down a 
copy of the object. Once you have picked 
up an object, you can use the tool’s pop-
up menu to clear it, or just Option-click 
a different object to pick that one up 
instead.

TOOL PALETTE
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Canvases
OmniGraffle Pro can work with documents containing many canvases. 
Each canvas is self-contained; it keeps track of its size, settings, and contents 
separately from the other canvases. For instance, you could keep one document 
for a project you’re working on, and have each canvas contain a diagram of a 
completely different aspect of the project.

Click the triangle next to a canvas to expand its constituent layers. Each layer has 
buttons to toggle its visibility, printability, and editability. You can select a canvas 
to work with all of its layers at once, or you can select a single layer to work with 
it individually. Drag canvases and layers around the list as you see fit, or even 
between documents. The color well next to a canvas sets its background color.

A master canvas can be applied to a canvas, where it acts like a kind of 
background layer. Drag a master canvas and drop it on a canvas to apply it. 
The canvas then depends on the master, and displays the contents of the master 
behind its own contents. Any subsequent changes to the master are reflected by 
the canvases that depend on it.

The controls at the bottom of the drawer are for creating, manipulating, and 
deleting your canvases, layers, and master canvases.

UTILITY DRAWER

Click the Canvases tab (in OmniGraffle Pro) or the Layers 
tab (in OmniGraffle Standard) at the top of the drawer to 
manage canvases and layers, or click the Outline tab to see 
the outline view.

Possibly The Most Entertaining New Feature
In addition to drawing with the Shape and Pen tools, dragging 
objects from a stencil, or creating items from the outline view, 
there is another truly cool way to rapidly make and connect 
objects. With a shape selected, Command-click an empty spot 
on the canvas to create a connected object there. Option-
Command-click an empty spot to create a sibling object instead 
of a child. Once you see this in action with the Diagram Layout 
inspector’s “Lay out diagrams after any connection change” 
option selected, you might never leave your home again.

Stencils
Rather than creating all of the objects you need one by one, you can 
pull ready-made objects from a stencil. Several handy stencils come with 
OmniGraffle, and you can download more from our web site. You can 
even make your own stencils from whichever objects you like.

Select the stencil you want from the Stencils menu, then just drag an object 
from the stencil to the canvas.

Diagram styles
When you turn an outline into a diagram, there is an infinite 
number of different ways you could style the items and lay them 
out. A diagram style is a special OmniGraffle file that acts as 
an example for how to graphically represent an essentially 
text-based outline. You can use one to specify how imported 
OmniOutliner files should look, or to style the outline you’re 
creating in OmniGraffle’s own outline view. Use the pop-up 
menu at the bottom of the outline view to select a style that 
works well for your diagram. If you like, you can even lay out 
a diagram the way you like it, save it as a diagram style, and 
share it with others.

Outline view
The outline view is a marvelously quick way to build a hierarchy of objects. For 
each item you type into the outline, a new object appears on the canvas. Press 
Return to create a new item; press Tab to indent the selected item or Shift-Tab 
to outdent it. You can also drag items around the outline as you see fit. The 
diagram automatically updates to reflect every change you make to the outline.

Toward the bottom of the drawer are buttons for creating, deleting, and modifying 
items in the outline, a diagram style menu, settings for how the diagram should 
behave while you edit the outline, and a preview of the current diagram style.
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PREFERENCES

General
The Preferences are application-wide settings that are in 
effect for every document you work on. We’ve tried to make 
OmniGraffle work the way you expect, but when it doesn’t, 
try making some adjustments here.

Tool Palette
Choose which tools you’d like to see and where you’d like to 
see them. You can also define a “hot key” for each tool; then 
while you are editing a diagram, hold a hot key to switch to 
that tool for as long as you are holding the key.

Templates
You can tell OmniGraffle to use a certain template for each 
new document you create. For more information about 
templates, see the next page (Save, print, import, export).

Presentation
In here are some options for OmniGraffle’s presentation 
mode. These mainly deal with highlighting objects during 
a presentation.

ColorSync
OmniGraffle Pro supports Apple’s ColorSync technology, 
which tries to keep colors as accurate as possible when 
viewed on any ColorSync-compliant display and when 
printed on any ColorSync-compliant printer. Use this pane 
to turn on ColorSync and set up color profiles.

Update
You can always be sure that your copy of OmniGraffle is up 
to date because it can automatically check for new versions 
of itself. Of course, OmniGraffle only checks when you have 
an active internet connection.
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Saving
The saving commands in the File menu act as you would expect in any 
application; Save writes any changes you’ve made to the file on the disk, 
while Save As.... writes your changes to a completely new file.

Select Save As Template... to create a file that can be used as a starting 
point for new documents. The Save As Diagram Style... command 
creates a file to which you can conform imported OmniOutliner files and 
hierarchies created with OmniGraffle’s outline view.

SAVE, PRINT, IMPORT, EXPORT

Exporting to other formats
To export a diagram is to tell OmniGraffle to do its best at approximating 
the diagram’s contents in some file format other than its own. You could, 
for instance, export to a Visio® XML file (for your Windows colleagues), a 
PNG or SVG file (for displaying on the web or e-mailing to friends), or even 
an OmniOutliner file (for people with excellent taste in idea organization 
applications). Exporting creates a new file in the selected format, leaving 
the original OmniGraffle file on your screen just the way it is.

LinkBack
LinkBack means you can copy content from one application and paste it 
into another application, without losing any of the content’s flexibility.

For example, say you copy some OmniGraffle objects and paste them into 
another LinkBack-compatible application, where they become embedded 
in the other application’s document. Days later, you could double-click the 
embedded data to edit it in OmniGraffle. When you save the changes, they 
are reflected in the other application immediately.

Importing from other formats
OmniGraffle can read a bunch of different file formats; just open a supported 
file normally from the File menu to open a copy of it as an OmniGraffle 
file. You can import diagrams from Visio® XML (in OmniGraffle Pro), DOT, 
and Diagram 2 files. You can also import outlines from OmniOutliner and 
apply outline styles to convert them to diagrams. If you are a technically-
minded person, you might like to import Project Builder, Interface Builder, 
EOModeler, and framework files to create visualizations of their contents.

Printing
The way OmniGraffle prints your diagram is largely determined by the 
Canvas Size inspector. Of course, all of the standard page setup and 
printing controls are available in the Page Setup and Print dialog boxes 
available from the File menu.

Templates
Templates are starting points for new documents. Say you tend 
to work with a particular paper size, orientation, grid, and 
canvas setup fairly often. Just create a document that looks the 
way you want your new documents to look, and save it as a 
template using the File ‣ Save As Template... command. You 
can then use File ‣ New From Template to select a template 
for your next document. You can also use the Templates 
preference pane to choose one template to use as the default 
for all new documents.
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Onscreen Help
OmniGraffle comes with an extensive onscreen help system, which 
covers all of the fiddly little details that this manual doesn’t. Just select 
OmniGraffle Help from the Help menu and you’ll find a searchable, 
browsable cornucopia of OmniGraffle knowledge.

HELP

Walkthroughs
We’ve prepared some interactive OmniGraffle documents to step you 
through using the software. If you’ve got a boxed copy of OmniGraffle, 
you can find them on the disc that came in the box. Otherwise, you can 
download them from our web site:
http://www.omnigroup.com/applications/omnigraffle/extras/

Further Help
Our web site is a nice first place to look for the latest information about 
OmniGraffle.
http://www.omnigroup.com/applications/omnigraffle/

There’s a OmniGraffle users’ mailing list, and you’re invited! Someone in 
the community just might be able to help you.
http://www.omnigroup.com/mailman/listinfo/omnigraffle-users

If you’re really stuck, or if you just want to let us know what you think, go ahead 
and e-mail us. Select Send Feedback... from the Help menu to conjure up a 
message addressed to us, or just write to omnigraffle@omnigroup.com. 
We’ll do our best to help you out.




